Какой хостинг необходим для OJS 3?

У Open Journal Systems есть официальный системные требования для хостинга:

  • PHP 7.3 или более новая с поддержкой MySQL, MariaDB или PostgreSQL
  • Сервер базы данных: MySQL/MariaDB 4.1 или более новая, или PostgreSQL 9.5 и более новая.
  • UNIX-like операционная система (такие как Linux, FreeBSD, Solaris, Mac OS X и т.д)

Под такие требования подходит большинство современных хостингов. Однако у некоторых хостингов по умолчанию бывают отключены обязательные функции или расширения PHP, например функция exec (без которой не работают обновления плагинов OJS) или расширение gettext, отсутсвие которого также может вызывать сбои в работе Open Journal Systems.

По нашему опыту мы рекомендуем хостинг Beget, который полностью подходит под системные требования OJS 3 и не имеет никаких технических ограничений. Вам не придется связываться с технической поддержкой хостинга для включения необходимых функций и расширений.

Для работы сайта с одним журналом будет достаточно виртуального хостинга со стартовым тарифом, если же у вас несколько журналов и периодичность выхода выпусков больше 6 в год, то можно выбрать тариф Noble.

хостинг для ojs

В любом случае, вы можете обратиться к нам и мы поможем вам зарегистрировать хостинг для OJS, а также помочь с выбором и регистрацией домена для вашего журнала.